Koszyk

[ 0 ] szt.
Pokaż koszyk
Twój koszyk jest pusty


Zalecenia dotyczące sprzętu i bazy Firebird

Sprzęt
Użytkownicy naszych programów niejednokrotnie pytają nas o sprzęt konieczny do obsługi baz EWOPISU, OŚRODKA i EWMAPY oraz o bazę Firebird. Zarówno EWOPIS, jak i OŚRODEK pracują na bazie SQL Firebird. Nowe bazy GESUT, BDOT500, EGiB, które są obsługiwane przez EWMAPĘ, także wymagają tej bazy. Rosną zatem wymogi dotyczące sprzętu, na którym pracuje wydział geodezji. Podczas rozmów telefonicznych często dowiadujemy się, że główny serwer działa pod kontrolą przestarzałego (bez wsparcia) systemu Windows 2003 w 32-bitowej wersji i 4GB RAM. Taki sprzęt jest niewystarczający do wygodnej pracy. W przypadku zakupu nowego sprzętu zalecane są następujące wymagania systemowe:

  • płyta 2 procesorowa
  • 2 procesory, po 4 rdzenie każdy i częstotliwości taktowania 3 GHz lub większej
  • minimum 16 GB RAM (zalecamy 32-64GB RAM)
  • zestaw szybkich dysków tworzących RAID o użytecznej pojemności minimum 1 TB – dyski SAS o prędkości 10k lub (co jest zalecane) 15k albo dyski SSD
  • zestaw pojemnych dysków SATA tworzących RAID o pojemności zależnej od rozmiaru skanowanego zasobu (efektywnie minimum 4 TB)
  • system Windows 2012 64-bitowy z odpowiednią liczbą licencji dostępowych (CAL).

Na szybkich dyskach oprócz systemu operacyjnego należy umieścić oprogramowanie, jak również bazy programu EWMAPA, EWOPIS i OŚRODEK. Obecnie program OŚRODEK umożliwia wskazanie różnych lokalizacji dla bazy podstawowej (fdb) oraz baz ze skanami i wytycznymi (fdr, fdw). Pliki *.fdr i *.fdw można umieścić na wolniejszych, lecz pojemniejszych dyskach SATA.

Firebird
Baza opensource Firebird nie posiada ograniczeń co do liczby użytkowników czy procesorów, zatem lepszy sprzęt oznacza lepszą wydajność bez ponoszenia kosztów licencyjnych. Korzystając z doświadczeń naszych użytkowników, zalecamy instalację bazy w wersji Classic (nie Superserver) na lepszym sprzęcie (minimum 4 rdzenie procesora). Wersja Classic potrafi efektywniej wykorzystać sprzęt komputerowy, zwłaszcza ten o lepszych parametrach (np. proponowany w niniejszym opisie).
Zalecaną wersją jest Firebird 2.52, chociaż nie zauważyliśmy kłopotów z innymi wersjami bazy. Firebird jest dystrybuowany w wersji 32 i 64-bitowej. Należy podkreślić, że wersja 64-bitowa otwiera wyłącznie bazy utworzone w Firebird 2.0 lub nowszym (zarówno 32-bitowym, jak i 64-bitowym). Nie są otwierane bazy utworzone w starszych wersjach Firebirda – co może dotyczyć baz EWOPISU. W tym przypadku należy wykonać backup na starej bazie i odtworzyć na nowej. Służy do tego program GBAK dostarczany razem z bazą Firebird. Dla bazy systemu OŚRODEK procedurę podniesienia wersji bazy należy przeprowadzić według opisu zawartego w pliku: osrodek_ods11_do_11_2.pdf.

Odwiedza nas 134 gości oraz 0 użytkowników.